CCNA Routing Switching Practice Test – 1 (Free)

Please enter your email:

1. What is the default Holdtime for HSRP?

 
 
 
 

2. In the following topology, how many collision domains are represented?

http://www.networkjourney.com

 
 
 
 

3. Consider the output of the show controllers commands issued on routers R1 and R2. Of these two routers, which one should have a clock rate set for the specified serial interface, and how do you know from the output?

R1#show controllers serial 0/2/0
Interface Serial0/2/0
Hardware is GT96K
DTE V.35idb at 0x47FFCA4C, driver data structure at 0x48004290
wic_info 0x480048BC
Physical Port 5, SCC Num 5
MPSC Registers:
MMCR_L=0x000304C0, MMCR_H=0x00000000, MPCR=0x00000100
CHR1=0x00FE007E, CHR2=0x00000000, CHR3=0x0000064A, CHR4=0x00000000
CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
CHR9=0x00000000, CHR10=0x00003008
SDMA Registers:
… OUTPUT OMITTED …

R2#show controllers serial 1/0
CD2430 Slot 1, Port 0, Controller 0, Channel 0, Revision 19
Channel mode is synchronous serial
idb 0x466767F0, buffer size 1524, V.35 DCE cable, clockrate 128000

Global registers
rpilr 0x2, rir 0x2, risr 0x0, rfoc 0x0, rdr 0x0
tpilr 0x1, tir 0x0, tisr 0x68, tftc 0x0, tdr 0x90
mpilr 0x3, mir 0x1, misr 0x60
bercnt 0xFF, stk 0x0
Per-channel registers for channel 0
… OUTPUT OMITTED …

 
 
 
 

4. Which of the following is a set of wiring standards that describe the color coding
of wires in RJ-45 connections?

 
 
 
 

5. You wish to Telnet into a Layer 2 Cisco Catalyst switch. Which of the following must be configured on the switch before you can Telnet into the switch?

 
 
 
 
 

6. On an IEEE 802.1Q trunk, what do we call the VLAN that is not tagged by 802.1Q?

 
 
 
 
 

7. Which of the following is considered to be a reliable Transport Layer protocol?

 
 
 
 
 

8. What is the range of assignable IP addresses for a subnet containing an IP
address of 172.16.1.10 /19?

 
 
 
 
 

9. You are working with an enterprise router connecting out to two Internet Service
Providers (ISPs). The router has a single link to each ISP. What type of topology
is described by this scenario?

 
 
 
 

10. Consider the following port security configuration:

Switch(config)# int gig 1/0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport port-security
Switch(config-if)# switchport port-security maximum 3
Switch(config-if)# switchport port-security mac-address sticky
Switch(config-if)# switchport port-security violation shutdown

What does the shutdown option in the bottom command do?
a. The shutdown option causes the port to go into an err-disable state if a port
security violation occurs.
b. The shutdown option causes the port to be administratively shutdown if a port
security violation occurs.
c. The shutdown option disables port security on this port.
d. The shutdown option drops traffic from the fourth MAC address seen on this
port, while permitting traffic from the first three MAC addresses learned on this
port. However, the security violation counter does not get incremented.
e. The shutdown option drops traffic from the fourth MAC address seen on this
port, while permitting traffic from the first three MAC addresses learned on this
port. Also, the security violation counter is incremented.

 
 
 
 
 

11. You are assigning IP addresses to hosts in the 192.168.4.0 /26 subnet. Which two of the following IP addresses are assignable IP addresses that reside in that subnet?

 
 
 
 
 

12. You are working with a Class B network with the private IP address of 172.16.0.0 /16. You need to maximize the number of broadcast domains, where each
broadcast domain can accommodate 1000 hosts. What subnet mask should you use?

 
 
 
 
 

13. Which of the following IPv6 address ranges is used for Global Unicast IPv6 addresses?

 
 
 
 
 
 
 

14. Which of the following technologies allows VPN tunnels to be setup and torn down on an as-needed basis?

 
 
 
 

15. Which of the following are security best practices when setting up a Cisco router? (Choose all the apply.)

 
 
 
 
 

16. In the diagram below, Client A is sending a packet to Host 1. Which devices will make a packet forwarding decision based on a destination IP address? (Choose 2.)

 
 
 
 

17. Consider the following topology and configuration for router R1.

http://www.networkjourney.com/practice-test/

ip access-list extended TEST
permit tcp any host 172.16.1.10 eq smtp
deny ip any 172.16.1.0 0.0.0.255
permit ip any 10.1.2.0 0.0.0.255
!
interface Serial 0/0
ip access-group TEST in
What traffic from the Internet will be allowed to pass through router R1? (Choose
all that apply.)

 
 
 
 

18. Which of the following is not a Rapid Spanning Tree Protocol (RSTP) port state?

 
 
 
 

19. In the diagram below, Client A is sending a packet to Host 1. As the packet is coming into the Fa 0/0 interface on router R2, what is the source IP address in the packet’s header?

 
 
 
 
 
 

20. What is the directed broadcast address of a subnet containing an IP address of 172.16.1.10 /19?

 
 
 
 
 

21. A PC has just booted up and wants to communicate with a host on a remote subnet. The PC knows the IP addresses of its default gateway and the remote host. However, in order to properly construct a frame, the PC needs an appropriate destination MAC address. What MAC address does the PC need to learn, and what protocol will the PC use to learn that MAC address?

 
 
 
 

22. You are configuring Network Address Translation (NAT). A PC on the inside of
your network has an IP address of 192.168.1.10. However, since that IP address
is a private IP address, it needs to be translated into an address that is routable
on the public Internet. What NAT terminology is used to describe the PC’s
192.168.1.10 IP address?

 
 
 
 

23. A router resides at what layer of the TCP/IP Model?

 
 
 
 
 

24. A host in your network has been assigned an IP address of 192.168.181.182 /25. What is the subnet to which the host belongs?

 
 
 
 
 

25. CDP (Cisco Discovery Protocol) resides at which layer of the OSI Model?

 
 
 
 
 

26. The PING utility uses which of the following protocols to check for network connectivity to an IP address?

 
 
 
 
 

27. BPDUGuard should be only be configured on ports that have which feature enabled?

 
 
 
 

28. Typically, HTTP uses what Transport Layer protocol and what port number?

 
 
 
 
 

29. You are configuring eBGP on router R1 seen in the figure. You want to form a BGP neighborship with router R2. Which command would you issue from within BGP router configuration mode on router R1?

 
 
 
 

30. You connect a laptop to an available port on a Cisco Catalyst switch. By default, how long does it take that port to start forwarding traffic?

 
 
 
 

Question 1 of 30